WireGuard gateway issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted May 23, 2025 - 15:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 23, 2025 - 13:08 UTC

Investigating

We are investigating issues with WireGuard over websockets (the default connection mode in flyctl).
`flyctl ssh`, `flyctl proxy`, `flyctl logs` commands as well as others may fail.

If you are on a network that allows UDP connections, running `fly wg websockets disable` may fix the issue as a workaround.
Posted May 23, 2025 - 11:34 UTC